您现在的位置:程序化交易>> 股票公式>> 其他>> 其他软件公式>>正文内容

解盘公式[其他软件公式]

相关标签:

 

原理解析:

BB赋值:BARPOS=SYSPARAM(1)
输出VARIABLE:WDAY[7]='星期六'
赋值:'星期日'
赋值:'星期一'
赋值:'星期二'
赋值:'星期三'
赋值:'星期四'
赋值:'星期五'
FY赋值:年份
FM赋值:月份
FD赋值:日
WD赋值:星期
P赋值:SYSPARAM(1)
STR1赋值:'日期:'+NUMTOSTR(FY[P],0)+'/'+NUMTOSTR(FM[P],0)+'/'+NUMTOSTR(FD[P],0)+' '+WDAY[WD[P]+1]
EXPLAIN(BARPOS=P,STR1),COLORFF
当满足条件BARPOS=P时,在最高价*1.12位置书写文字,ALIGN2,COLORFF
当满足条件SYSPARAM(2)=BARPOS时,在收盘价位置书写文字,ALIGN4,COLORCCFFCC
V1赋值:最高价的30日简单移动平均*1.15
V2赋值:最高价的3日简单移动平均*1.03
V3赋值:最低价的3日简单移动平均*0.97
V4赋值:最低价的30日简单移动平均*0.85
输出GET:收盘价TT5%的之字转向,线宽为3,COLORFFFFFF
工作线赋值:收盘价的1日简单移动平均
输出趋势线:收盘价的18日简单移动平均,CIRCLEDOT,COLORFFFF
输出强势线:收盘价的3日简单移动平均,线宽为3,COLORFF
输出多头线:(2*(收盘价-收盘价*0.2)+开盘价-开盘价*0.2+最高价-最高价*0.2+最低价-最低价*0.2)/5*成交量(手)的8日累和/成交量(手)的8日累和,线宽为5,COLOR99FF
输出空头线:8日内多头线的最低值,线宽为5,COLORFF00
收盘价-收盘价*0.2,线宽为5,COLORFF
VAR1赋值:若2日前的最高价=5日内最高价的最高值则将最近3周期置为1
VAR2赋值:VAR1上穿0.9
VAR3赋值:若2日前的最低价=5日内最低价的最低值则将最近3周期置为1
VAR4赋值:VAR3上穿0.9
输出分析家公式网HTTP://WWW.70822.COM整理:上次VAR2距今天数日前的最高价,CROSSDOT,线宽为2,COLOREA91B5
当满足条件收盘价时,在上次VAR2距今天数日前的最高价和上次VAR2距今天数日前的最高价位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLOREA91B5
输出支撑:上次VAR4距今天数日前的最低价,CROSSDOT,线宽为2,COLOR3791B5
当满足条件收盘价时,在上次VAR4距今天数日前的最低价和上次VAR4距今天数日前的最低价位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLOR3791B5
当满足条件VAR2时,在最高价*1.03位置书写文字,COLORE40E
VAR5赋值:如果VAR2,返回最高价,否则返回如果VAR4,返回最低价,否则返回0
VAR6赋值:若2日前的最高价=5日内最高价的最高值ANDLOW<1日前的最低价ANDHIGH<1日前的最高价则将最近3周期置为1
VAR7赋值:若2日前的最高价=5日内最高价的最高值ANDLOW>1日前的最低价ANDHIGH>1日前的最高价则将最近3周期置为1
VAR8赋值:若2日前的最高价=5日内最高价的最高值ANDHIGH<1日前的最高价ANDLOW>1日前的最低价ANDREF(最低价,1)>2日前的最低价ANDREF(最高价,1)<2日前的最高价则将最近3周期置为1
VAR9赋值:若2日前的最低价=5日内最低价的最低值ANDLOW>1日前的最低价ANDHIGH>1日前的最高价则将最近3周期置为1
VARA赋值:若2日前的最低价=5日内最低价的最低值ANDLOW<1日前的最低价ANDHIGH<1日前的最高价则将最近3周期置为1
VARB赋值:若2日前的最低价=5日内最低价的最低值ANDHIGH<1日前的最高价ANDLOW>1日前的最低价ANDREF(最低价,1)>2日前的最低价ANDREF(最高价,1)<2日前的最高价则将最近3周期置为1
当满足条件VAR9上穿0.9时,在最低价*0.97位置书写文字,COLORFF
当满足条件VARA上穿0.9时,在最高价*1.01位置书写文字,COLORE5E9
输出现价:收盘价,POINTDOT,COLORFF
阻挡赋值:最高价的21日[2日权重]移动平均*1.05
RSV赋值:(收盘价-13日内最低价的最低值)/(13日内最高价的最高值-13日内最低价的最低值)*100
K赋值:RSV的3日[1日权重]移动平均
D赋值:K的3日[1日权重]移动平均
J赋值:3*K-2*D
RSV12赋值:(收盘价-34日内最低价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)*100
K12赋值:RSV12的3日[1日权重]移动平均
D12赋值:K12的3日[1日权重]移动平均
J12赋值:3*K12-2*D12
RSV24赋值:(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100
K24赋值:RSV24的3日[1日权重]移动平均
D24赋值:K24的3日[1日权重]移动平均
J24赋值:3*K24-2*D24
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为9,0不为0则画空心柱.,COLORFF5B00
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为8,0不为0则画空心柱.,COLORFF6C00
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为7,0不为0则画空心柱.,COLORFF7B00
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为6,0不为0则画空心柱.,COLORFF9C00
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLORFFBE00
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3.5,0不为0则画空心柱.,COLORFFCC00
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORFFFF00
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为9,0不为0则画空心柱.,COLOR70084
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为8,0不为0则画空心柱.,COLORA3
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为7,0不为0则画空心柱.,COLORB7
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为6,0不为0则画空心柱.,COLORCD
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLORE9
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR754E9
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR76EF3
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR77BF3
当满足条件收阳线时,在开盘价和最低价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR726CA
当满足条件收阳线时,在收盘价和最高价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR726CA
当满足条件收阴线时,在收盘价和最低价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORDE9100
当满足条件收阴线时,在开盘价和最高价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORDE9100
当满足条件收盘价/开盘价>1.04ANDCLOSE<阻挡ANDCLOSE-1日前的收盘价>0时,在收盘价和开盘价位置之间画柱状线,宽度为9,0不为0则画空心柱.,COLOR90FF
当满足条件收盘价/开盘价>1.04ANDCLOSE<阻挡ANDCLOSE-1日前的收盘价>0时,在收盘价和开盘价位置之间画柱状线,宽度为8,0不为0则画空心柱.,COLOR9FFF
当满足条件收盘价/开盘价>1.04ANDCLOSE<阻挡ANDCLOSE-1日前的收盘价>0时,在收盘价和开盘价位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLORB5FF
当满足条件收盘价/开盘价>1.04ANDCLOSE<阻挡ANDCLOSE-1日前的收盘价>0时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLORE4FF
当满足条件收盘价/开盘价>1.04ANDCLOSE<阻挡ANDCLOSE-1日前的收盘价>0时,在开盘价和最低价位置之间画柱状线,宽度为0.7,0不为0则画空心柱.,COLORFFFF
当满足条件收盘价/开盘价>1.04ANDCLOSE<阻挡ANDCLOSE-1日前的收盘价>0时,在收盘价和最高价位置之间画柱状线,宽度为0.7,0不为0则画空心柱.,COLORFFFF
当满足条件收盘价<1日前的收盘价ANDCLOSE<1日前的收盘价ANDHIGH>阻挡ANDCLOSE<阻挡时,在开盘价和最低价位置之间画柱状线,宽度为0.7,0不为0则画空心柱.,COLORFF76FF
当满足条件收盘价<1日前的收盘价ANDCLOSE<1日前的收盘价ANDHIGH>阻挡ANDCLOSE<阻挡时,在收盘价和最高价位置之间画柱状线,宽度为0.7,0不为0则画空心柱.,COLORFF76FF
当满足条件收盘价<1日前的收盘价ANDCLOSE<1日前的收盘价ANDHIGH>阻挡ANDCLOSE<阻挡时,在收盘价和开盘价位置之间画柱状线,宽度为9,0不为0则画空心柱.,COLORFF00FF
当满足条件收盘价<1日前的收盘价ANDCLOSE<1日前的收盘价ANDHIGH>阻挡ANDCLOSE<阻挡时,在收盘价和开盘价位置之间画柱状线,宽度为6,0不为0则画空心柱.,COLORFF62FF
当满足条件收盘价<1日前的收盘价ANDCLOSE<1日前的收盘价ANDHIGH>阻挡ANDCLOSE<阻挡时,在收盘价和开盘价位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLORFF76FF
当满足条件收盘价<1日前的收盘价ANDCLOSE<1日前的收盘价ANDHIGH>阻挡ANDCLOSE<阻挡时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLORFFA8FF
 

源码:

 

BB:=BARPOS=SYSPARAM(1);
VARIABLE:WDAY[7]='星期六';
WDAY[1]:='星期日';
WDAY[2]:='星期一';
WDAY[3]:='星期二';
WDAY[4]:='星期三';
WDAY[5]:='星期四';
WDAY[6]:='星期五';
FY:=YEAR;
FM:=MONTH;
FD:=DAY;
WD:=WEEKDAY;
P:=SYSPARAM(1);
STR1:='日期:'+NUMTOSTR(FY[P],0)+'/'+NUMTOSTR(FM[P],0)+'/'+NUMTOSTR(FD[P],0)+' '+WDAY[WD[P]+1];
EXPLAIN(BARPOS=P,STR1),colorFF;
DRAWTEXT(BARPOS=P,HIGH*1.12,STR1),ALIGN2,colorFF;
DRAWTEXT(SYSPARAM(2)=BARPOS,CLOSE,'收益:'+NUMTOSTR(FINANCE(33),2)+'\n'+'净资:'+NUMTOSTR(FINANCE(34),2)+'\n'+'流通:'+NUMTOSTR(FINANCE(7)/10000,2)+'亿'+'\n'+'流通:'+NUMTOSTR(FINANCE(7)/FINANCE(1)*100,0)+' %'+'\n'+'权益:'+NUMTOSTR(FINANCE(36),0)+' %'+'\n'+'主营:'+NUMTOSTR(FINANCE(53),0)+' %'+'\n'+'利润:'+NUMTOSTR(FINANCE(54),0)+' %'+'\n'+'主营:'+NUMTOSTR(FINANCE(20)/10000,1)+'亿'+'\n'),ALIGN4,colorCCFFCC;
V1:=MA(HIGH,30)*1.15;
V2:=MA(HIGH,3)*1.03;
V3:=MA(LOW,3)*0.97;
V4:=MA(LOW,30)*0.85;
GET:ZIG(3,TT5),LINETHICK3,colorFFFFFF;
工作线:=MA(CLOSE,1);
趋势线:MA(CLOSE,18),CIRCLEDOT,colorFFFF;
强势线:MA(CLOSE,3),LINETHICK3,colorFF;
多头线:SUM((2*(CLOSE-CLOSE*0.2)+OPEN-OPEN*0.2+HIGH-HIGH*0.2+LOW-LOW*0.2)/5*VOL,8)/SUM(VOL,8),LINETHICK5,color99FF;
空头线:LLV(多头线,8),LINETHICK5,colorFF00;
CLOSE-CLOSE*0.2,LINETHICK5,colorFF;
VAR1:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);
VAR2:=CROSS(VAR1,0.9);
VAR3:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);
VAR4:=CROSS(VAR3,0.9);
压力:REF(HIGH,BARSLAST(VAR2)),CROSSDOT,LINETHICK2,colorEA91B5;
STICKLINE(CLOSE,REF(HIGH,BARSLAST(VAR2)),REF(HIGH,BARSLAST(VAR2)),5,0),colorEA91B5;
支撑:REF(LOW,BARSLAST(VAR4)),CROSSDOT,LINETHICK2,color3791B5;
STICKLINE(CLOSE,REF(LOW,BARSLAST(VAR4)),REF(LOW,BARSLAST(VAR4)),5,0),color3791B5;
DRAWTEXT(VAR2,HIGH*1.03,'我闪'),colorE40E;
VAR5:=IF(VAR2,HIGH,IF(VAR4,LOW,0));
VAR6:=BACKSET(REF(HIGH,2)=HHV(HIGH,5) AND LOW<REF(LOW,1) AND HIGH<REF(HIGH,1),3);
VAR7:=BACKSET(REF(HIGH,2)=HHV(HIGH,5) AND LOW>REF(LOW,1) AND HIGH>REF(HIGH,1),3);
VAR8:=BACKSET(REF(HIGH,2)=HHV(HIGH,5) AND HIGH<REF(HIGH,1) AND LOW>REF(LOW,1) AND REF(LOW,1)>REF(LOW,2) AND REF(HIGH,1)<REF(HIGH,2),3);
VAR9:=BACKSET(REF(LOW,2)=LLV(LOW,5) AND LOW>REF(LOW,1) AND HIGH>REF(HIGH,1),3);
VARA:=BACKSET(REF(LOW,2)=LLV(LOW,5) AND LOW<REF(LOW,1) AND HIGH<REF(HIGH,1),3);
VARB:=BACKSET(REF(LOW,2)=LLV(LOW,5) AND HIGH<REF(HIGH,1) AND LOW>REF(LOW,1) AND REF(LOW,1)>REF(LOW,2) AND REF(HIGH,1)<REF(HIGH,2),3);
DRAWTEXT(CROSS(VAR9,0.9),LOW*0.97,'买入'),colorFF;
DRAWTEXT(CROSS(VARA,0.9),HIGH*1.01,'考虑'),colorE5E9;
现价:CLOSE,POINTDOT,colorFF;
阻挡:=SMA(HIGH,21,2)*1.05;
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
RSV12:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K12:=SMA(RSV12,3,1);
D12:=SMA(K12,3,1);
J12:=3*K12-2*D12;
RSV24:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=3*K24-2*D24;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,9,0),colorFF5B00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,8,0),colorFF6C00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,7,0),colorFF7B00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,6,0),colorFF9C00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,5,0),colorFFBE00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3.5,0),colorFFCC00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1.5,0),colorFFFF00;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,9,0),color70084;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,8,0),colorA3;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,7,0),colorB7;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,6,0),colorCD;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,5,0),colorE9;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,3,0),color754E9;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,1.5,0),color76EF3;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,1,0),color77BF3;
STICKLINE(CLOSE>OPEN,OPEN,LOW,1,0),color726CA;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,1,0),color726CA;
STICKLINE(OPEN>CLOSE,CLOSE,LOW,1,0),colorDE9100;
STICKLINE(OPEN>CLOSE,OPEN,HIGH,1,0),colorDE9100;
STICKLINE(CLOSE/OPEN>1.04 AND CLOSE<阻挡 AND CLOSE-REF(CLOSE,1)>0,CLOSE,OPEN,9,0),color90FF;
STICKLINE(CLOSE/OPEN>1.04 AND CLOSE<阻挡 AND CLOSE-REF(CLOSE,1)>0,CLOSE,OPEN,8,0),color9FFF;
STICKLINE(CLOSE/OPEN>1.04 AND CLOSE<阻挡 AND CLOSE-REF(CLOSE,1)>0,CLOSE,OPEN,4,0),colorB5FF;
STICKLINE(CLOSE/OPEN>1.04 AND CLOSE<阻挡 AND CLOSE-REF(CLOSE,1)>0,CLOSE,OPEN,2,0),colorE4FF;
STICKLINE(CLOSE/OPEN>1.04 AND CLOSE<阻挡 AND CLOSE-REF(CLOSE,1)>0,OPEN,LOW,0.7,0),colorFFFF;
STICKLINE(CLOSE/OPEN>1.04 AND CLOSE<阻挡 AND CLOSE-REF(CLOSE,1)>0,CLOSE,HIGH,0.7,0),colorFFFF;
STICKLINE(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,1) AND HIGH>阻挡 AND CLOSE<阻挡,OPEN,LOW,0.7,0),colorFF76FF;
STICKLINE(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,1) AND HIGH>阻挡 AND CLOSE<阻挡,CLOSE,HIGH,0.7,0),colorFF76FF;
STICKLINE(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,1) AND HIGH>阻挡 AND CLOSE<阻挡,CLOSE,OPEN,9,0),colorFF00FF;
STICKLINE(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,1) AND HIGH>阻挡 AND CLOSE<阻挡,CLOSE,OPEN,6,0),colorFF62FF;
STICKLINE(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,1) AND HIGH>阻挡 AND CLOSE<阻挡,CLOSE,OPEN,4,0),colorFF76FF;
STICKLINE(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,1) AND HIGH>阻挡 AND CLOSE<阻挡,CLOSE,OPEN,2,0),colorFFA8FF;

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,交易模型,选股公式,还原公式的朋友

可联系技术人员 QQ: 262069696  点击在线交流或微信:cxhjy888 进行 有偿收费 编写!(注:由于人数限制,QQ或微信请选择方便的一个联系我们就行,加好友时请简单备注下您的需求,否则无法通过。谢谢您!)

怎么收费,代编流程等详情请点击查阅!

(注:由于人数限制,QQ或微信请选择方便的一个联系我们就行,加好友时请简单备注下您的需求,否则无法通过。谢谢您!)

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容